This project has moved. For the latest updates, please go here.

Windows Home Server?

Jan 15, 2010 at 10:09 PM

Hi,

This wrapper seems to be just what I was looking for, but as soon as I add the line:

TaskService ts = new TaskService();

to my Windows Home Server Add-in it no longer works (I get an error message from WHS saying there is a problem with the Add-in).

Should it work or are there some other steps I need to take to get it to work in this scenario?

 

Thanks

 

Coordinator
Jan 21, 2010 at 6:48 PM

I'm just guessing as I have no WHS to try this on, but I would check on run permissions. Add-ins typically run in a more secure sandbox than regular code. The Task Scheduler requires Admin privileges to run and your plug-in may not have that. I would write a really simple piece of code, maybe copying something on the project home page or in the Documentation area, to see if you can run it stand-alone on WHS. If that fails then there are different problems. If not, then you know it has something to do with the plug-in environment. Another thought is that this is a .NET 2.0 library so you plug-in will have to accommodate that version.

Jan 24, 2010 at 3:59 PM

Hi again,

I have tried just putting the add-in into a Windows Form application and that runs correctly on the WHS machine, I was logged in as Administrator when I ran the program. So I think your theory is right. Does that mean that I can't use this approach in my WHS add-in?

 

Thanks

 

ChangedDaily

 

Coordinator
Jan 25, 2010 at 9:15 AM

You can try decorating your class with the System.Security.Permissions.PermissionSetAttribute attribute to try and get your code trusted. Beyond that, I'm not sure what to tell you other than to look on WHS forums for more info on permissions, .NET code, and plug-ins. Good luck. If you find a solution, please be sure to post it here so others don't have to go looking.