This project has moved and is read-only. For the latest updates, please go here.
1

Closed

Exception Error The current version of the native library (1.1) does not support the original or minimum version ...

description

When I tried to get the Task.Definition.Actions on Windows 10 Version 1607
I got
"Exception Error The current version of the native library (1.1) does not support the original or minimum version of the ..."

I looked at the source code in TaskService/Task.cs and found the function
internal static int GetOSLibraryMinorVersion() returns 1 instead of 5
and that cause the above error
I belive the issue to do with Environment.OSVersion.Version.Major is set to 10 in my case rather than 6 because I embded manfist file with my program

To reproduce the issue you would need to emabed a manfist file with your program and
then call something like the follwoing

string Allatasks = "";
TaskService taskService = new TaskService();

foreach (var task in taskService.AllTasks)
{
            try
            {
                    Allatasks  += task.Definition.Actions.ToString()) + "\r\n";
            }
            catch (Exception ex)
            {
                ...
            }
        }
}

Please note this happen only when I embed a amnifist file with the program
Closed Jun 11 at 10:05 PM by dahall
This has been fixed in 2.5.27 released today.

comments