This project has moved and is read-only. For the latest updates, please go here.

The request is not supported 0x80070032

Oct 19, 2011 at 10:27 AM
Edited Oct 19, 2011 at 10:29 AM

Hi All:

I use this wrapper(in my winform app) well to run a remote host'scheduler from one win xp 32bit computer,

but a error happen(

The request is not supported 0x80070032


 when i run my winform app into a win 7 64 bit computer.

any suggestion???

thanks a lot.

Oct 19, 2011 at 3:17 PM

Will you provide the code that throws this exception? That error condition can occur in a number of circumstances.

Oct 19, 2011 at 4:36 PM
Edited Oct 19, 2011 at 4:44 PM

Hi dahall:

thank for your reply.

here is my code:

    public class EmailSenderWindowTask
	//remote Server        
	private string WindowSchedulerServer = System.Configuration.ConfigurationManager.AppSettings["EmailSenderWindowSchedulerServer"];        
	private string WindowSchedulerName = System.Configuration.ConfigurationManager.AppSettings["EmailSenderWindowSchedulerName"];       
	private DomainUser dUser = new DomainUser();        
    	public void Run()
                    using (TaskService ts = new TaskService(WindowSchedulerServer, dUser.Name, dUser.Domain, dUser.Password, false))             		

            public void Run(int pid)         	
                    using (TaskService ts = new TaskService(WindowSchedulerServer, dUser.Name, dUser.Domain, dUser.Password, false))             		

        private void button2_Click(object sender, EventArgs e)
                new EmailSenderWindowTask().Run();
                MessageBox.Show("Test Ok");
            catch (Exception ex)
                MessageBox.Show(string.Format("Exception:{0}", ex.Message));

BTW,My window form app must set Platform target to only x86 for runn in the win 7 64bit.
Oct 19, 2011 at 11:50 PM

Does the TaskService constructor, the GetTask method, or the Run method throw the exception?

Oct 20, 2011 at 10:49 AM

Hi dahall:

ok i will try to get which throw the exception.

I give you another exception first.

System.Runtime.InteropServices.COMException (0x80070032): The requester is not supported ( HRESULT: 0x80070032)

Oct 20, 2011 at 3:56 PM

Without knowing which call into the library is throwing the exception, it is almost impossible to determine the cause.

Oct 21, 2011 at 4:21 AM

hi dahall:

After I test, the  TaskService constructor throw this Exception.



Oct 21, 2011 at 2:26 PM

Sometimes this happens when the Task Scheduler service or the Windows Event Log service has not been started. This can also happen on systems that have been imaged (sys prep'd) incorrectly.

Sep 20, 2012 at 10:52 AM

I'm experiencing exactly the same problem. Trying to create a remote task, the code runs on Win7 32Bit, the destination PC is 2003 Server. Manually I can create a task to run on another computer, all good - which likely means that my system is suitably configured. But TaskService constructor throws with 0x80070032.

May 7, 2013 at 3:52 PM
I am having the same problem connecting to a 2003 Server
The request is not supported. (Exception from HRESULT: 0x80070032)

my code is fairly simple, I'm just trying to connect at the moment
string strUsername = ConfigurationManager.AppSettings["Username"];
            string strPassword = ConfigurationManager.AppSettings["Password"];
            string strServer = ConfigurationManager.AppSettings["Server"];
            string strDomain = ConfigurationManager.AppSettings["Domain"];

            using (TaskService ts = new TaskService(strServer, strUsername, strDomain, strPassword))
                foreach (Task task in ts.RootFolder.Tasks)
                    string strName = task.Name;
has anyone found the source of this problem or a solution?

Oct 31, 2013 at 9:22 PM
Edited Oct 31, 2013 at 9:23 PM
FWIW, after trial and error I was able to connect to a 2003 server by specifying true for the forceV1 parameter and dropping the preceding backslashes from the targetServer parameter (ex. "SERVERNAME" instead of "\\SERVERNAME").
Marked as answer by dahall on 5/3/2014 at 5:04 PM
May 2, 2014 at 8:52 PM
I found a solution for this problem. A Firewall setting needs to be set.

Go to: Windows Firewall => Allowed Programs, scroll down to "Remote Scheduled Task Management" and check that option. In my case just checking the "domain" option was enough.
Marked as answer by dahall on 5/3/2014 at 5:04 PM