This project has moved. For the latest updates, please go here.

Some tasks not running

Topics: Errors
Jan 15, 2014 at 5:31 PM
Hi all,
I made tasks (about 900 tasks) using this library.
when i tried create only one task, it runs perfectly.
But when I created 900 tasks, not all tasks run.
I've enabled triggers and settings.
If i run the task manually, it runs well, but it doesn't run as schedule.
somebody can help me?
Coordinator
Jan 15, 2014 at 9:43 PM
My guess is that it has something to do with re-using triggers between different tasks. The way to know for sure is to pull the XML (using the system tool Task Scheduler) for the task that works and for some that don't and compare them. If there are triggers missing or malconfigured, my guess is that you are re-using triggers or their properties between registrations. Best practice is create all task information (trigger, action, settings) and then register the task within a single context and release all references before going to the next task instance.
Marked as answer by dahall on 9/1/2015 at 10:12 AM