This project has moved and is read-only. For the latest updates, please go here.

error load assembly

Topics: Errors
Apr 27, 2016 at 10:37 PM
Hello I try to run my application on end-user PC, windows 7, net fram. 4.0

when the app try to app the TaksEditDialog show a exption with the message:
"Could not load file or assembly 'TimeSpan2, Version='"

I 'm using the version of these dll, it is in execute path.

Some idea?

Apr 28, 2016 at 6:51 AM
Edited Apr 28, 2016 at 6:52 AM
I met this problem at past, I solved it by using the Nuget Management to specify TimeSpan2 2.1.3 instead of 2.1.4 (VS2015 has this feature).
Hope this helpful.
Apr 28, 2016 at 7:14 AM
OMG I'm using VS2012, how can resolve it?
Apr 28, 2016 at 8:57 AM
Edited Apr 28, 2016 at 8:58 AM
Maybe you can modify the configure file manually, but it is definitely not safe.
I met this problem when I use 2.5.17, If you are use 2.5.17, you can try to upgrade to 2.5.19. Maybe it will be solved.
Marked as answer by dahall on 4/29/2016 at 9:52 AM
Apr 28, 2016 at 5:01 PM
Hello thanks for your help, I updated to 2.5.19 and now it work ok, buuuuut.... Now I have error when try to GetTast() on WIndows XP, say cannot find file expecified, any idea?

Apr 29, 2016 at 8:24 AM
Post some demo source code will be helpful to find out the issue.
Apr 29, 2016 at 5:07 PM
I solve it In XP, when GetTask() if the task not exist generate error, therefore with tryCath I create the task and continue jejeje
Task t = ts.GetTast(name);
if(t !=null)
//genare error because is XP and the task not exists
NewTask();//bla bla bla
Marked as answer by dahall on 4/29/2016 at 9:52 AM